Apple security update for OSX 10.5 intel only...

For those of you who are still running OSX 10.5 (Leopard) on a G4 or G5 processor, take note that it is almost certainly time to buy new hardware.

Apple has released a security update for Leopard, but for intel macs only. 

Apple announced the switch to intel processors back in 2005 and by mid 2007 had switched all their computers to the processor. In 2009 they introduced OSX 10.6 (Snow Leopard) which was available only for intel based Macs.

If you have managed to keep your old G4 or G5 Mac running all this time, congrats to you. However, it may be finally time to upgrade your hardware as it appears there will be no further updates for the operation systems you can run on the old hardware.

If you are interested in such things, there is a good timeline of the transition here.